Изучение данных

Временной ряд изображений — это набор изображений, сделанных в разное время в одном и том же месте, полезных для понимания изменения области во времени. Например, временной ряд изображений лесного массива может показать, когда деревья были вырублены, а затем отросли заново, или когда и где происходили пожары или нашествия вредителей. Поскольку такие нарушения обычно сопровождаются резкими изменениями значений пикселов изображений, анализ временных рядов изображений использует алгоритмы для обнаружения этих изменений.

Дополнительный модуль ArcGIS Image Analyst предлагает два алгоритма обнаружения изменений временных рядов для изображений. Один из них — алгоритм Landtrendr, который использует изображения Landsat и обычно применяется для работы с лесом. Поскольку снимки Landsat-TM обеспечивают непрерывное покрытие земной поверхности с 1984 года, их можно использовать для отслеживания изменений почвенно-растительного покрова на протяжении многих лет.

Сначала вы познакомитесь с многомерным растровым изображением района Западных Каскадных гор в штате Орегон. Многомерный растр является моделью набора данных, используемой для представления временных рядов изображений. После этого вы подготовите временной ряд изображений для анализа и изучите, как изменился почвенно-растительный покров в пределах одного пиксела изображения.

Изучение многомерного растра

Сначала вы загрузите проект, содержащий все данные для этого руководства, и откроете его в ArcGIS Pro. Затем вы ознакомитесь с многомерным растровым набором данных, который будете использовать на протяжении всего руководства.

  1. Загрузите пакет проекта Forest_Disturbance_Analysis.
  2. Перейдите к скачанному файлу и дважды щелкните по нему, чтобы открыть проект в ArcGIS Pro. Если будет предложено, войдите под лицензированной учетной записью ArcGIS.
    Примечание:

    Если у вас нет доступа к ArcGIS Pro или учетной записи организации ArcGIS, см. варианты доступа к программному обеспечению.

    Проект содержит карту изображений района Западных Каскадных гор в штате Орегон.

    Проект по умолчанию

    На панели Содержание перечислены слои проекта. Слой WestCascade.crf содержит временной ряд из 78 спутниковых изображений типа Landsat Analysis Ready Imagery (ARD), полученных в период с 1984 по 2020 год в районе Западных Каскад в Орегоне, США. Каждое изображение представлено в виде многоканального растра, который содержит синий, зеленый, красный, инфракрасный и коротковолновый инфракрасный спектральные каналы. Все изображения были получены летом, поэтому на деревьях есть листья, и они находятся на схожей стадии роста, что важно для обеспечения требований алгоритма LandTrendr, который вы будете использовать в этом руководстве. Кроме того, были включены только изображения с облачным покровом менее 10 процентов. Все эти растры собраны в один многомерный растр, сохраненный в формате CRF.

    Примечание:

    Чтобы применить описанный в этом руководстве рабочий процесс к вашей собственной изучаемой области, вы можете создать аналогичный многомерный растр, загрузив изображения Landsat ARD из USGS EarthExplorer для вашей области интереса. Чтобы очистить изображения и создать многомерный растр, прочитайте статью Очистка изображений Landsat: удаление облаков и их теней.

    Затем вы просмотрите 78 изображений, включенных в файл WestCascade.crf, и узнаете, когда было получено каждое из них.

  3. В панели Содержание щелкните слой WestCascade.crf, чтобы его выбрать.

    WestCascade.crf на панели Содержание

    Если выбран многомерный набор данных, вкладка Многомерный появляется на ленте. Вкладка содержит инструменты для работы с многомерными растрами.

  4. На ленте щелкните вкладку Многомерный.

    Вкладка Многомерные

  5. В группе Срез текущего отображения щелкните ниспадающий список StdTime. Щелкните второе значение в списке, начинающееся с даты 1984-07-19.

    Раскрывающееся меню StdTime

    Карта обновляется для показа изображения, сделанного 19 июля 1984 года. Во временном ряду изображений WestCascade.crf каждое изображение можно назвать временным срезом. Изображение, которое вы только что показали, является вторым временным срезом в ряду.

    Второй срез времени на карте

    На панели Содержание в легенде слоя отображаются спектральные каналы, использованные для показа изображения.

    Легенда для слоя WestCascade.crf

    Изображение отображается с использованием комбинации каналов естественных цветов, где канал 1 — синий, канал 2 — зеленый, а канал 3 — красный. Эта комбинация каналов приблизительно соответствует тому, как ландшафт виден человеческому глазу. Изображение также содержит инфракрасный канал (канал 4) и два коротковолновых инфракрасных канала (канал 5 и канал 6). Эти каналы будут использоваться позднее, хотя в настоящее время они не отображаются.

    Примечание:

    Чтобы узнать больше о мультиспектральных изображениях и комбинациях каналов, ознакомьтесь с руководством Начало работы с изображениями.

    На изображении в основном видны лесные массивы (зеленые), но в центре изображения также есть участки, на которых деревья были вырублены (бежевые).

    Очистка вырубленных участков на карте

    Вы также можете анимировать временные ряды, чтобы увидеть все изображения подряд.

  6. На вкладке Многомерный в группе Срез текущего отображения щелкните кнопку Воспроизвести разрезы по StdTime.

    Кнопка Воспроизвести срезы по StdTime

    Временной ряд воспроизводится в виде анимации, при этом новое изображение отображается каждые несколько секунд. Лес иногда значительно меняется от снимка к снимку, а иногда меняется лишь немного.

    Примечание:

    На некоторых изображениях присутствуют области NoData, которые выглядят как отверстия в слое. Эти области соответствуют пикселам облаков, которые были замаскированы и не повлияют на анализ.

  7. Когда закончите, нажмите на кнопку Воспроизвести срезы по StdTime ещё раз, чтобы остановить анимацию.

    Затем вы просмотрите свойства слоя.

  8. На панели Содержание дважды щелкните слой WestCascade.crf.

    Откроется окно Свойства слоя.

  9. Щелкните вкладку Источник. Разверните разделы Многомерная информация, SR и StdTime.

    Вкладка Источник в окне Свойства слоя

    Значение Количество указывает на то, что набор данных содержит 78 временных срезов. Значение пиксела SR соответствует отражательной способности поверхности. Диапазон временного Экстента — с 1984-07-03 по 2020-08-23.

  10. Закройте окно Свойства слоя.

    В итоге слой WestCascade.crf содержит 78 мультиспектральных изображений. Каждое изображение содержит 6 спектральных каналов. То есть всего набор данных содержит 468 растров. На следующем изображении показана структура многомерного растра:

    Структура многомерного растра

Применение формулы индекса

Для анализа временных рядов изображений вы будете использовать алгоритм LandTrendr. Алгоритм LandTrendr работает с многомерным растром, в котором каждый временной срез представляет собой одноканальный растр. Но ваши временные срезы состоят из 6 каналов. Для получения единого растрового изображения для каждого временного среза необходимо применить формулу индекса к временному ряду. Вы будете использовать Нормализованный индекс гарей (NBR), который хорошо подходит для различения здорового леса от лесных нарушений и часто используется для обнаружения следов выгорания в лесу.

Примечание:

Чтобы узнать больше об индексе NBR, ознакомьтесь с руководством Оценка гарей на спутниковых изображениях.

  1. Убедитесь, что в панели Содержание выбран слой WestCascade.crf.
  2. На ленте щелкните вкладку Изображения. В группе Инструменты щелкните Индексы.

    Кнопка Индексы на ленте

  3. В списке индексов в разделе Ландшафт щелкните NBR.

    Опция NBR в списке индексов

    Появится окно NBR. Индекс NBR объединяет ближний инфракрасный и коротковолновый каналы с помощью математической формулы. В вашем слое эти каналы соответствуют 4 и 6 каналам, соответственно.

  4. В окне NBR для Индекса канала Ближний инфракрасный выберите 4 — Band_4. Для Индекса канала Коротковолновый инфракрасный выберите 6 — Band_6.

    Параметры инструмента NBR

  5. Нажмите OK.

    На карту добавляется слой с именем NBR_WestCascade.crf. Этот слой по-прежнему является многомерным растром, но он содержит только один канал растра NBR на временной срез.

    Примечание:

    Инструмент NBR -- это растровая функция, которая динамически генерирует новый растровый слой. Такой подход экономит время обработки, но новый слой существует только в оперативной памяти вашего компьютера. Если вы удалите слой из своего проекта, он будет удален, и вам нужно будет его воссоздать.

    По умолчанию слой отображается с помощью черно-белой растяжки. Вы измените символы, чтобы подчеркнуть различия между здоровой и поврежденной растительностью (отсутствием здоровой растительности).

  6. На панели Содержание щелкните правой кнопкой символ NBR_WestCascade.crf и разверните ниспадающий список. Поставьте отметку Показать имена и выберите цветовую шкалу Розово-зеленый (плавный переход).

    Цветовая шкала Розово-зеленый (плавный переход)

    На карте символы обновляются. Самые большие значения пикселов NBR отображают здоровый лес и теперь показаны зеленым цветом. Самые низкие значения пикселов NBR отображают нарушенные участки и отображаются фиолетовым. Пикселы NBR со средними значениями представлены белым или светло-зеленым цветами.

    Карта NBR с розово-зелеными символами

    Новый слой тоже является временным рядом.

  7. Убедитесь, что в панели Содержание выбран слой NBR_WestCascade.crf.
  8. На ленте щелкните вкладку Многомерный. В группе Срез текущего отображения для параметра StdTime разверните ниспадающий список и выберите временной срез для 1984-07-19.

    Карта обновляется, отобразив космический снимок за эту дату, которая обозначается так же.

  9. Задайте для значения StdTime снова первый временной срез (1984-07-03).

Изменение диаграммы для одного пиксела

Затем вы будете использовать временные ряды NBR, чтобы начать изучение изменений леса с течением времени. В этом руководстве вы будете отслеживать изменения в лесных массивах различными способами. Сначала вы будете отслеживать изменения отдельного пиксела с помощью панели Анализатор изменения пикселов временных рядов.

На вашей карте в настоящее время отображается растр NBR за 3 июля 1984 г. Если выбрать один пиксел на этом растре и понаблюдать за тем, как менялись его значения с 1984 по 2020 год на всех 78 временных срезах, то эти значения можно представить на графике, как показано на следующем изображении:

Диаграмма, показывающая, как значения пиксела менялись с течением времени

Затем вы можете использовать алгоритм LandTrendr, чтобы найти общие тенденции на этой диаграмме. LandTrendr найдет точки перегиба, в которых изменяется траектория значений пиксела, и затем поместит данные в кусочно-линейную модель. В результате получится аппроксимирующая кривая, состоящая из нескольких сегментов прямой, идущих от одной точки перегиба к следующей, как показано на следующем изображении:

Диаграмма, показывающая данные, подогнанные к кусочно-линейной модели

Каждый сегмент представляет собой изменение, произошедшее за период времени, характеризующееся временем начала, временем окончания, продолжительностью, уклоном и величиной (то есть, сколько изменений произошло между временем начала и временем окончания). На приведенном изображении есть три сегмента:

  • Первый сегмент представляет собой здоровый лес (высокие и стабильные значения NBR).
  • Второй сегмент указывает на нарушение, такое как вырубка (быстрое уменьшение значений NBR).
  • Третий сегмент представляет собой процесс восстановления леса по мере того, как деревья вырастают (медленное увеличение значений NBR).

Вы создадите подобную диаграмму для своих данных.

  1. Убедитесь, что в панели Содержание выбран NBR_WestCascade.crf.
  2. На ленте во вкладке Многомерные в группе Анализ щелкните стрелку ниспадающего списка Временной профиль и выберите Анализатор изменения пикселов временных рядов.

    Опция Анализатор изменения пикселов временных рядов

    Появится пустой вид диаграммы и панель Свойства диаграммы.

  3. В панели Свойств диаграммы на вкладке Данные для Метода обнаружения изменений выберите LandTrendr.

    Опция LandTrendr

    Примечание:

    Появившееся предупреждающее сообщение, говорящее о том, что построение транспонирования (которое является дополнительным хранилищем, оптимизированным для анализа временных рядов) улучшит производительность. Слой растровой функции NBR_WestCascade.crf не имеет транспонирования, а лежащий в основе многомерный растр WestCascade.crf имеет. Предупреждение можно не читать.

    Для удобства точка диаграммы отмечена в слое Pixel_location.

  4. На панели Содержание поставьте отметку Местоположение пиксела.

    Отметка Местоположение пиксела

    На карте появится зеленая точка. Вы перейдете к ее местоположению с помощью закладки.

  5. На ленте щелкните вкладку Карта. В группе Навигация нажмите Закладки и выберите закладку Pixel point.

    Закладка Pixel point

    Карта переместится к пикселу, отмеченному данной точкой. Вы отобразите диаграмму для этого пиксела.

  6. На панели Свойства диаграммы в разделе Задание местоположения пиксела щелкните кнопку Точка.

    Кнопка Точка

  7. На карте щелкните интересующий пиксел.

    Интересующий вас пиксел на карте

    На карту добавится ​​серая точка. На панели Свойства диаграммы в список местоположений пикселов добавляется строка. Прежде чем создать диаграмму для этого местоположения пикселов, вы выберете несколько опций стиля.

  8. На панели Свойства диаграммы в строке расположения пиксела в разделе Символ щелкните символ точки и выберите Критский синий.

    Опция Критский синий в инструменте выбора цветовой палитреа

    Примечание:

    Чтобы увидеть имя изображения, наведите на него курсор.

  9. Установите размер на 3.

    Параметр Размер символа

  10. В разделе Параметры модели для параметра Показать кривую подгонки с щелкните линию Цвет и выберите Янтарно-золотой.

    Опция Янтарно-золотой в инструменте выбора цвета

  11. Измените толщину линий на 3.

    Параметр толщины линии

  12. В разделе Параметры модели нажмите Подогнать и создать диаграмму.

    В панели диаграммы появится диаграмма.

    Диаграмма, показывающая изменение пиксела с течением времени

    Синие точки отображают значения пикселов для 78 временных срезов. Оранжевая линия — это аппроксимирующая кривая, рассчитанная с использованием алгоритма LandTrendr, которая показывает общие тенденции изменений.

Изучение диаграммы изменения значений пиксела

После этого вы изучите диаграмму.

  1. На панели диаграммы наведите курсор на одну из синих точек.

    Год временного среза и его значение NBR

    Всплывающее окно, отображающее год временного среза и его значение NBR.

    Оранжевая кривая подгонки состоит из нескольких сегментов, каждый из которых соответствует важному этапу в истории пиксела. В легенде диаграммы показывается время начала и окончания каждого сегмента кривой подгонки.

    Легенда диаграммы

    Подсказка:

    Щелкните любой элемент легенды диаграммы, чтобы включить или выключить соответствующий сегмент на диаграмме.

    В настоящий момент есть пять линейных сегментов. Возможно, это не оптимальное количество сегментов для понимания данных. Вы измените число сегментов кривой подгонки. Нахождение оптимального количества сегментов может быть достигнуто методом проб и ошибок и будет зависеть от вашего набора данных.

  2. На панели Свойства диаграммы разверните группу Параметры модели. Измените Максимальное число сегментов на 4.

    Параметр Максимальное число сегментов

    Примечание:

    Для получения дополнительной информации о каждом параметре модели см. Анализ изменений с помощью LandTrendr.

  3. Нажмите Подогнать и обновить диаграмму.

    Диаграмма обновлена ​​и теперь содержит только четыре сегмента:

    • Первый сегмент с высокими значениями NBR указывает на стабильный зрелый лес.
    • На втором участке наблюдается сильное повреждение леса. Площадь здорового леса быстро сократилась до нуля, вероятно, из-за вырубки леса на этой территории.
    • Третий сегмент показывает кривую быстрого восстановления, поскольку саженцы деревьев были посажены и относительно быстро выросли.
    • В четвертом сегменте восстановление продолжается, но медленнее, поскольку здесь молодые деревья развиваются до полной зрелости.
  4. На диаграмме наведите курсор на сегменты кривой.

    Подгонка модели для сегмента

    Во всплывающем окне отображается модель подгонки для данного сегмента. Подбор модели представлен ​​формулой в формате ax + b, где a — это уклон, а b — точка пересечения. Также показано значение RMSE (среднеквадратическая ошибка).

    Чтобы лучше понять изменения в интересующей вас области, вы изучите соответствующие растровые изображения.

  5. На панели инструментов вида диаграммы щелкните кнопку Легенда.

    Кнопка Легенда

    Легенда отключится, раскрывая диаграмму.

  6. На диаграмме дважды щелкните синюю вершину, чтобы выбрать временной срез.
    Подсказка:

    Либо вы можете перетащить курсор, чтобы нарисовать вокруг вершины рамку.

    Выбор точки на диаграмме

    Карта обновится, отобразив изображение для выбранного вами временного среза.

    Примечание:

    Если выбрать определенную точку на диаграмме сложно, вы можете увеличить масштаб диаграммы. На панели инструментов диаграммы нажмите кнопку Режим масштабирования и нарисуйте рамку вокруг интересующей вас точки.

  7. Визуализируйте четыре временных среза, выделенных на следующем изображении:

    Точки для визуализации

    На карте вы видите следующие четыре временных среза:

    Изображения, показывающие изменения с течением времени

    Эти временные срезы иллюстрируют изменения в этом местоположении пиксела: от зрелого леса к участку вырубки, затем к молодым деревьям и снова к зрелому лесу.

  8. Закройте вид диаграммы и панель Свойства диаграммы.
  9. На панели Содержание снимите отметку Местоположение пиксела.
  10. Щелкните правой кнопкой слой NBR_WestCascade.crf и выберите Приблизить к слою.

    Опция Приблизить к слою

    Вы вернетесь к полному экстенту данных.

  11. На Панели инструментов быстрого доступа щелкните кнопку Сохранить проект.

    Кнопка Сохранить проект на панели инструментов быстрого доступа

    Проект сохранен.

Вы настроили проект в ArcGIS Pro, познакомились с многомерным растром и изучили изменения лесного покрова на уровне отдельного пиксела. Теперь вы перенесете свое понимание изменений в лесных массивах на все изображение в целом.


Определение нарушения и восстановления лесов

Для анализа изменений всех пикселов изображения сначала необходимо создать растровое изображение для анализа изменений. Затем вы создадите карту нарушений леса, чтобы идентифицировать такие события, как лесозаготовки и пожары, на протяжении всего периода изучения леса. Наконец, вы создадите карту восстановления леса, чтобы оценить, сколько времени потребовалось, чтобы нарушенные участки вернулись к состоянию зрелого леса.

Создание растра анализа изменений

В этом разделе вы будете использовать инструмент Анализировать изменения с помощью LandTrendr для создания растра анализа изменений. В этом инструменте используется тот же алгоритм LandTrendr, что и в инструменте Анализатор изменения пикселов временных рядов, но он применяет его ко всем пикселам многомерного растра, а не к одному пикселу. Результатом будет растр анализа изменений, который захватывает всю информацию о кривых подгонки для каждого пиксела.

  1. Убедитесь, что в панели Содержание выбран слой NBR_WestCascade.crf.
  2. На ленте щелкните вкладку Многомерный. В группе Анализ для галереи инструментов щелкните кнопку Дополнительно.

    Кнопка Дополнительно для галереи инструментов Многомерный

  3. Щелкните инструмент Анализ изменений с помощью LandTrendr.

    Инструмент Анализ изменений с помощью LandTrendr

    Откроется панель Геообработка c инструментом.

  4. Для Выходной многомерный растр введите WestCascade_change_analysis.crf.

    Параметры инструмента Анализ изменений с помощью LandTrendr

    Остальные параметры оставьте по умолчанию.

    Примечание:

    Выходными данными этого инструмента является многомерный растр с одним временным срезом за год. Перед выполнением анализа изменений LandTrendr инструмент выбирает лучшие значения пикселов, доступные во входном растре для каждого года. Для заданного года наилучшими значениями пикселов являются значения временного среза, который наиболее близок к значению параметра Дата привязки (по умолчанию 6–30 или 30 июня). Если лучшим значением пиксела является NoData из-за облака, инструмент берет значение пиксела из следующего ближайшего временного среза.

  5. Щелкните Запустить.
    Примечание:

    Процесс может длиться 15 минут или дольше. Процесс выполнения может не показываться до завершения работы.

    Запустится обработка. По завершении в панели Содержание появится выходной растр, и его первый канал отобразится на карте.

    Слой WestCascade_change_analysis.crf — это многомерный растр, состоящий из 34 временных срезов, то есть примерно по одному в год (за пару лет данных не было). Каждый временной срез представляет собой многоканальный растр, в котором каналы хранят информацию о подогнанной модели LandTrendr. Вы изучите и покажете эти каналы растра.

  6. На панели Содержание щелкните символ WestCascade_change_analysis.crf.

    Символ для WestCascade_change_analysis.crf

    Появится панель Символы.

  7. На панели Символы для Канала раскройте ниспадающий список.

    Ниспадающее меню Канал

    Если формула ax + b представляет подогнанную модель для одного сегмента подогнанной кривой, применяется следующее:

    • В канале Slope хранится значение a, которое описывает направление изменения, такое как увеличение или уменьшение.
    • Канал Intercept хранит значение b.
    • Канал Fitted_Value хранит значение, интерполированное из модели подгонки для заданного времени. В этом наборе данных это приблизительное значение входного значения NBR для каждого временного среза.
    • Канал RMSE хранит среднеквадратичную ошибку подогнанной кривой.
    • Канал Change_Magnitude хранит величину изменения, то есть разницу между подогнанными значениями в начале и в конце периода изменения.
    Примечание:

    Все перечисленные каналы имеют название, начинающееся с Band_1, например, Band_1_Slope, поскольку они были получены из растра NBR, в котором для каждого временного среза есть один канал, названный Band_1.

    Используя этот растр анализа изменений, можно извлечь информацию об изменениях, такую ​​как дата изменения, продолжительность изменения и величина изменения. В оставшейся части руководства этот многомерный растр будет использоваться в качестве входных данных для выполнения различных задач обнаружения изменений.

    В настоящее время канал Band_1_Slope отображается на карте. Вместо него вы отобразите другой канал.

  8. В списке каналов выберите Band_1_Fitted_Value.

    Карта обновится.

    Канал подогнанных значений на карте

    Темно-зеленые области представляют самые низкие подогнанные значения NBR, а темно-фиолетовые области -- самые высокие. Также можно отобразить диапазон Band_1_Fitted_Value для разных временных срезов, используя опцию StdTime на вкладке Многомерные.

  9. Закройте панель Символы.

Карта нарушений

Теперь, когда у вас есть растр анализа изменений, вы можете использовать его для отображения другой информации. Во-первых, вы отобразите на карте нарушения леса с течением времени, используя инструмент Определить изменения, используя растр анализа изменений. Вы запустите инструмент с параметрами, заданными для обнаружения случаев резкого уменьшения подогнанных значений NBR, что означает внезапное изменение леса от состояния здорового леса до отсутствия деревьев.

  1. Подтвердите, что в панели Содержание выбран слой WestCascade_change_analysis.crf.
  2. На ленте во вкладке Многомерные в группе Анализ разверните галерею инструментов и выберите Определить изменения, используя растр анализа изменений.

    Кнопка Определить изменения, используя растр анализа изменений

    Инструмент появится на панели Геообработка.

  3. Для Выходной растр введите Disturbance.crf.

    Вы зададите направление изменений таким образом, чтобы обнаруживались только уменьшающиеся изменения, что позволит зафиксировать участки, где был затронут здоровый лес. Вы также сможете отслеживать время самых ранних изменений, чтобы знать, когда начались нарушения.

  4. В поле Изменить направление выберите По убыванию. Для Тип изменения выберите Время самого раннего изменения.

    Параметры инструмента Определить изменения, используя растр анализа изменений

    Перед запуском инструмента вам также необходимо отфильтровать результаты, чтобы выделить события, длящиеся не более 4 лет (что означает резкое изменение), со снижением показателя NBR от высокого значения от 0,7 до 1 (здоровый лес) до низкого значения от -1 до 0,35 (отсутствие деревьев). Диапазоны значений пикселов были выбраны путем анализа типичных значений для здорового леса и вырубленных или выжженных участков в растровых каналах Band_1_Fitted_Value.

  5. Разверните раздел Фильтр по атрибутам. Укажите параметры следующим образом:
    • Отметьте Фильтр по продолжительности.
    • Для Максимальная продолжительность (в годах) введите 4.
    • Отметьте Фильтр по начальному значению.
    • Для Минимальное начальное значение введите 0.7.
    • Для Максимальное начальное значение введите 1.
    • Отметьте Фильтр по конечному значению.
    • Для Минимальное конечное значение введите -1.
    • Для Максимальное конечное значение введите 0.35.

    Параметры Фильтра по атрибутам

  6. Щелкните Запустить.

    Слой Disturbation.crf создан и добавлен на карту. Это одноканальный растр (не многомерный). Значение каждого пиксела представляет дату, когда началось событие вырубки или пожара.

  7. Закройте панель Геообработка.
  8. На панели Содержание отключите WestCascade_change_analysis.crf и NBR_WestCascade.crf.
  9. На карте щелкните нарушенные области.

    Появится всплывающее окно с датой начала события нарушения.

    Всплывающее сообщение о нарушении

  10. Закройте всплывающее окно.

Заполнить пропущенные значения

В растре Disturbance.crf в нарушенных областях присутствуют пиксели NoData, для которых не хватило информации для построения достоверной модели. Однако вполне вероятно, что эти области имеют такое же значение нарушения, что и окружающие пикселы. Вы заполните эти области NoData с помощью растровой функции Статистика, используя значение большинства из соседних пикселов.

  1. На ленте щелкните вкладку Изображения. В группе Анализ щелкните Функции растра.

    Кнопка Функции растра

    Появится панель Функции растра.

  2. На панели Функции растра найдите Статистика. В группе Статистические нажмите функцию Статистика.

    Кнопка Статистика

    Вы зададите параметры инструмента так, что для каждого пиксела NoData инструмент будет изучать прямоугольник размером 3x3 пиксела вокруг него и выбирать значение, которое чаще всего встречается в этой окрестности.

  3. Для Растр выберите Disturbance.crf.
  4. Для Тип статистики выберите Большинство. Убедитесь, что Количество строк и Количество столбцов установлены на 3.
  5. Поставьте отметку Заполнить только пикселы NoData.

    Параметры функции растра Статистика

  6. Щелкните Создать новый слой.

    Новый растровый слой Statistics_Disturbance.crf добавлен на карту. Этот слой более сглаженный и чистый, с меньшим числом пустот в нарушенных областях. Вы переименуете слой и измените его символы.

  7. Закройте панель Функции растра.
  8. На панели Содержание щелкните Statistics_Disturbance.crf, чтобы сделать его имя доступным для редактирования. Введите Smoother_Disturbance.crf и нажмите Enter.

    Слой Smoother_Disturbance.crf

  9. Щелкните символ Smoother_Disturbance.crf.

    Появится панель Символы. Вместо того чтобы самостоятельно задавать символы, вы импортируете подготовленный для вас файл слоя, который включен в ваш проект.

  10. На панели Символы щелкните кнопку опций и выберите Импорт из файла слоя.

    Опция Импорт из файла слоя

    Появится окно Импорт символов.

  11. В окне Импорт символов дважды щелкните Папки, Forest_Disturbance_Analysis, commondata и userdata. Выберите Disturbance_symbology.lyrx.

    Окно Импорт символов

  12. Нажмите OK.

    Применяются новые символы с переходом от белого к пурпурному цвету.

    Карта нарушений с новыми символами

    Темно-фиолетовые области отображают нарушения, произошедшие в последние годы, а белые или светло-розовые области - нарушения, произошедшие в более ранние периоды. Большинство из нарушений возникло в результате лесозаготовительных работ, которые начались в центре региона и со временем расширились в северном и южном направлениях. Лесозаготовки на больших территориях на востоке и западе областей не велись.

  13. Закройте панель Символы.
  14. На панели Содержание щелкните правой кнопкой Disturbance.crf и выберите Удалить.

Проверка нарушений

Затем вы изучите слой нарушений леса, чтобы лучше понять, какие вырубки и пожары произошли в лесу Западных Каскадов. Сначала вы сравните эти события с границами охраняемых лесных территорий, находящихся в ведении федерального правительства и правительства штата.

  1. На панели Содержание включите слой Границы лесопользования.

    Участки, на которых не ведется лесозаготовка, являются областями, находящимися под охраной государства.

    Слой Границы лесопользования на карте

  2. На ленте щелкните вкладку Карта. В группе Навигация нажмите стрелку ниспадающего списка Исследовать и убедитесь, что выбран Верхний слой.

    Опция меню Верхний слой

    Эта опция гарантирует, что всплывающие окна будут отображаться только для самого верхнего слоя, перечисленного на панели Содержание. В данном случае это слой Границы лесопользования.

  3. На карте щелкните по большой охраняемой лесной зоне в восточной части карты, чтобы отобразилось ее всплывающее окно.

    Всплывающее окно национального парка

    Эта область — национальный парк. Вы изучите ее более подробно.

  4. Закройте всплывающее окно.
  5. На ленте на вкладке Карта в группе Навигация щелкните Закладки и выберите State park.

    Карта переместится к парку. Некоторые пикселы в центре парка показаны темно-фиолетовым, что указывает на то, что здесь в последние годы имели место нарушения.

    Закладка State park на карте

    Может быть, дело в незаконных вырубках в охраняемом лесу? Вы узнаете больше об этом конкретном событии.

  6. В группе Навигация щелкните ниспадающий список Исследовать и выберите Видимые слои.

    Опция Видимые слои

    Эта опция гарантирует, что во всплывающих окнах будет отображаться информация обо всех отображаемых слоях, а не только о верхнем слое.

  7. Щелкните область нарушения, чтобы отобразить всплывающее окно.

    Год нарушения

    Во всплывающем окне дата возникновения нарушения указана в файле Smoother_Disturbance.crf. Это нарушение имело место в 2017 году.

  8. Закройте всплывающее окно.

    Вы просмотрите изображения, соответствующие этой области, показав карты рядом.

  9. На панели Каталог разверните Карты. Щелкните правой кнопкой Source_Images и выберите Открыть.
    Примечание:

    Если вы не видите панель Каталог, щелкните вкладку Вид на ленте. В группе Окна щелкните Панель Каталог.

    Опция Открыть

    Появится карта Source_Images. Отобразится WestCascade.crf — исходный многомерный растр со снимками.

  10. Перетащите вкладку Source_Images и закрепите ее справа от карты Disturbance_Analysis.

    Зона закрепления справа

    Вы свяжете две карты так, чтобы они отображали одинаковый экстент.

  11. Щелкните вкладку Вид на ленте. В группе Связь щелкните стрелку ниспадающего меню Связать виды и выберите Центрировать и масштабировать.

    Опция центрирования и масштабирования

  12. Увеличьте масштаб и переместите карту к нарушенному участку национального парка.

    Две карты обновляются синхронно. Вы увидите изображение для даты вскоре после события нарушения.

  13. Щелкните вкладку карты Source_Images, чтобы сделать ее активной.

    Вкладка Source_Images

  14. В панели Содержание выберите WestCascade.crf.
  15. На ленте щелкните вкладку Многомерный. Для StdTime выберите временной срез 2018-07-17.

    Изображения обновляются. Эта область не выглядит лишенной растительности, а скорее коричневатой, поскольку деревья не были вырублены, а были затронуты пожаром.

    Сравнение нарушенной области между картами

    Далее вы просмотрите, как некоторые давние или недавние события нарушений отображаются на самых последних изображениях.

  16. На ленте щелкните вкладку Карта. Щелкните Закладки и выберите Linked view.
  17. Убедитесь, что вкладка карты Source_Images активна. На ленте во вкладке Многомерные для StdTime выберите самый последний временной срез 2020-08-23.

    С помощью связанных карт можно увидеть следующее:

    • Многие из самых старых зон нарушений (белые или светло-розовые) теперь заполнены взрослыми деревьями, потому что лес полностью восстановился.
    • Там, где нарушения произошли несколько лет назад (средний фиолетовый цвет), молодые деревья только подрастают.
    • Для самых последних нарушений (темно-фиолетовый) на изображениях все еще видна в основном голая земля.

    Восстановление на недавних изображениях

  18. Закройте карту Source_Images.
  19. Щелкните вкладку Вид на ленте. Щелкните кнопку Связать виды, чтобы отменить связь между видами.

Измерение восстановления леса

Лес — это динамическая система, включающая в себя циклы нарушения и восстановления. Например, вырубают деревья для заготовки древесины и высаживают новые деревья. Процесс восстановления обычно протекает намного медленнее, чем событие нарушения. Чтобы оценить продолжительность процесса восстановления, когда повторно пересаженные деревья вырастут до зрелого возраста, вы можете снова запустить инструмент Выявить изменения, используя анализ изменений. На этот раз вы извлечете даты начала и окончания периодов изменения, когда значения NBR увеличились, а не уменьшились. Затем вы рассчитаете количество лет между датами начала и окончания. Полный рабочий процесс состоит из следующих действий:

  • Найдите период внесения изменений для восстановления и извлеките начальную дату изменений.
  • Запустите инструмент еще раз, чтобы получить дату окончания изменений.
  • Вычислите разницу между двумя датами (количество дней восстановления).
  • Преобразуйте количество дней в количество лет, разделив на 365,25.

Для сохранения времени вам не нужно выполнять все эти действия вручную. Вы запустите весь рабочий процесс целиком как модель геообработки:

Модель геообработки

  1. На панели Каталог раскройте Наборы инструментов и Forest_Disturbance_Analysis.tbx. Дважды щелкните Calculate Recovery Duration.

    Модель Calculate Recovery Duration

    Откроется панель Геообработка, показывающая модель в виде инструмента.

  2. Для парамера Input Change Analysis Raster выберите WestCascade_change_analysis.crf. Отключите Использовать отфильтрованные записи.
  3. Для Output Recovery Raster удалите имеющийся текст и введите Recovery_years.crf.
    Примечание:

    Если рядом с пунктом Output Recovery Raster отображается предупреждающий символ, поскольку местоположение сохранения выходных данных не существует. Чтобы гарантировать использование правильного места сохранения, убедитесь, что вы удалили весь текст перед вводом имени выходного файла.

    Параметры Calculate Recovery Duration

  4. Щелкните Запустить.

    Через несколько секунд выходной растр будет создан и добавлен на карту. Это одноканальный растр, где значения пикселов - это количество лет восстановления.

    Слой Recovery_years.crf на панели Содержание

  5. На панели Содержание щелкните правой кнопкой Recovery_years.crf и выберите Приблизить к слою. Выключите Границы лесопользования и Smoother_Disturbance.crf.

    Теперь вы можете увидеть слой на карте.

    Слой восстановления на карте

    Многие участки, подвергшиеся вырубке, окрашены в темно-розовый цвет, что означает, что на их восстановление потребовалось от 11 до 15 лет и более. В то время как нарушения обычно происходят быстро, для восстановления леса может потребоваться достаточно много времени.

  6. Закройте панель Геообработка.
  7. Сохраните проект.

Используя растр анализа изменений, вы нанесли на карту нарушения и измерили время, необходимое лесу для восстановления. Затем вы проанализируете изменения леса, классифицировав растровое изображение, полученное в результате анализа изменений.


Классификация изменений лесного покрова

Чтобы получить более полное представление о том, как изменился лесной покров региона Западные Каскады, вы создадите карту классификации лесов для каждого временного среза. В процессе классификации каждому пикселу будет присвоен один из следующих трех классов:

  • Здоровый лес
  • Нарушен
  • Восстановлен

Классификация временного ряда изображений влечет за собой классификацию каждого пиксела в каждом временном срезе. Вместо классификации временного ряда исходного изображения WestCascade.crf вы будете классифицировать производный растр анализа изменений, WestCascade_change_analysis.crf, который вы создали ранее в этом руководстве. Для определения текущего состояния леса инструмент классификации будет использовать информацию, хранящуюся во всех каналах растра анализа изменений, включая Fitted_Value, Slope, Intercept и Change_Magnitude. Рабочий процесс классификации временного ряда аналогичен классификации отдельного изображения, но каждый обучающий образец необходимо создать для определенного временного среза и отметить датой этого среза.

Примечание:

Чтобы узнать больше о классификации одного изображения, см. руководство Вычисление водонепроницаемых поверхностей по спектрозональным снимкам.

Вам предстоит выполнить следующий рабочий процесс:

  • Загрузите схему классификации.
  • Соберите обучающие выборки с помощью инструмента, поддерживающего время, Менеджер обучающей выборки.
  • Выберите классификатор и обучите его на обучающих выборках. В этом руководстве вы будете использовать классификатор произвольных деревьев.
  • Классифицируйте временные ряды с помощью обученного классификатора.
  • Создайте диаграмму, чтобы отобразить итоговую информацию результатов классификации.

Изучение растра анализа изменений

Чтобы лучше понять процесс классификации, вы изучите каналы растра анализа изменений с символами RGB. Сначала вы создадите новую карту.

  1. На панели Каталог, в разделе Карты, щелкните правой кнопкой карту Classification и выберите Открыть.

    Карта откроется только с базовой картой и WestCascade.crf. Вы добавите только растр анализ изменений.

  2. На панели Каталог разверните Папки, Forest_Disturbance_Analysis и commondata. Щелкните правой кнопкой мыши WestCascade_change_analysis.crf и выберите Добавить к текущей карте.

    Опция Добавить к текущей карте

    По умолчанию отображается первый временной срез (1984-06-30). Вы измените временной срез и символы.

  3. Убедитесь, что в панели Содержание выбран WestCascade_change_analysis.crf.
  4. На ленте щелкните вкладку Многомерный. Для StdTime выберите временной срез 1987-06-30.
  5. На панели Содержание щелкните символ WestCascade_change_analysis.crf.

    Появится панель Символы.

  6. На вкладке Символы задайте следующие параметры:
    • Для Основные символы выберите RGB.
    • Для Красный выберите Band_1_Slope.
    • Для Зеленый выберите значение Band_1_Fitted_Value.
    • Для Синий выберите Band_1_Change_Magnitude.

    Символы RGB

    Карта обновится. Символы RGB комбинируют три канала в единое композитное изображение красного, зеленого и синего цветов. Этот способ отображения позволяет определить, как различные значения Slope, Fitted_Value и Change_Magnitude могут указывать на различные состояния леса.

  7. На ленте щелкните вкладку Карта. Щелкните Закладки и выберите Детали RGB.

    Примеры RGB

    В зависимости от значений трех каналов цвет различных областей варьируется от ярко-зеленого до ярко-розового. В следующем списке объясняется, что означает каждый цвет:

    • Здоровый зрелый лес — светло-зеленый: значение Fitted_Value высокое, а Slope более или менее пологий (близок к 0). Область, покрытая стабильным, здоровым лесом.
    • Здоровый зрелый лес, вскоре подлежащий вырубке — ярко-зеленый: значение Fitted_Value высокое, а Slope — сильно отрицательное. Участок здорового леса, который будет использоваться для лесозаготовок в следующих временных срезах.
    • Нарушение — темно-зеленый цвет: значение Fitted_Value от среднего до очень низкого, а Slope — сильно отрицательное. Нарушенный участок, на котором ведется вырубка деревьев.
    • Нарушение, но скоро произойдет восстановление — ярко-розовый цвет: значение Fitted_Value очень низкое, а Slope — сильно положительное. Нарушенная область, которая впоследствии будет засажена деревьями и начнет восстанавливаться в следующие временные срезы.
    • Восстановление — светло-розовый: Fitted_Value — среднее значение, а Slope — положительное. Область, которая в настоящее время восстанавливается, где молодые деревья вырастают в зрелые.
  8. Закройте панель Символы.
  9. На панели Содержание щелкните правой кнопкой файл WestCascade_change_analysis.crf и выберите Приблизить к слою.

    Процесс классификации будет использовать информацию, хранящуюся в каналах Fitted_Value, Slope и других, чтобы решить, как классифицировать каждый пиксел.

Загрузка схемы классификации

Теперь, когда вы лучше понимаете то, как процесс классификации будет использовать информацию из каналов, вы начнете рабочий процесс классификации, загрузив схему классификации.

Примечание:

В этом руководстве для вас подготовлен файл схемы классификации. Чтобы создать свой собственный файл схемы, обратитесь к документации Менеджер обучающих выборок.

  1. Убедитесь, что в панели Содержание выбран WestCascade_change_analysis.crf.
  2. На ленте щелкните вкладку Изображения. В группе Классификация изображений щелкните Инструменты классификации и выберите Менеджер обучающих выборок.

    Опция Менеджер обучающей выборки

    Появится панель Классификация изображений, отображающая схему по умолчанию. Вы загрузите схему для этого руководства.

  3. На панели Классификация изображений щелкните Схема классификации.

    Кнопка Схема классификации

  4. В окне Загрузить схему дважды щелкните Папки, Forest_Disturbance_Analysis, commondata и userdata. Щелкните WestCascadeForestTypes.ecs.

    WestCascadeForestTypes.ecs в окне Загрузить схему

  5. Нажмите OK.

    Схема появится на панели Классификация изображений. На ней перечислены три целевых класса, которые соответствуют трем типам лесов.

    Схема классификации на панели Классификация изображений

Сбор обучающих выборок

Теперь вы соберете обучающие выборки для классификации изображений. Сначала вы измените символы слоя WestCascade_change_analysis.crf, чтобы упростить идентификацию местоположений хороших выборок.

  1. На панели Содержание щелкните правой кнопкой файл WestCascade_change_analysis.crf и выберите Символы.
  2. На панели Символы задайте следующие параметры:
    • Для Основные символы выберите Растяжка.
    • Для Канал выберите значение Band_1_Fitted_Value.
    • Для Цветовая схема выберите цветовую шкалу Оттенки зеленого (плавный переход).

    Символы для подогнанных значений

    Карта обновится, отобразив подогнанные значения NBR. Самые низкие значения соответствуют белому цвету, а самые высокие — ярко-зеленому.

    Вы должны собрать выборки, иллюстрирующие все три целевых класса, взяв примеры в разных временных срезах. Первая выборка, которую вы создадите, будет относиться к здоровому лесу в активный в данный момент временной срез (1987-06-30).

  3. Закройте панель Символы. На панели Классификация изображений щелкните класс Здоровый лес, чтобы выбрать его.
  4. Щелкните кнопку Полигон.

    Кнопка Полигон на панели Классификация изображений

  5. На карте приблизьте участок здорового леса (ярко-зеленый).
  6. Щелкните по карте, чтобы оцифровать вершины полигона внутри здорового леса. Дважды щелкните последнюю точку, чтобы завершить полигон.

    Полигон здорового леса на карте

    Примечание:

    Чтобы лучше идентифицировать местоположения выборок, вы можете в качестве дополнения к виду подогнанных значений просмотреть тот же временной срез исходного изображения WestCascade.crf.

    На панели Классификация изображений в список выборок добавляется обучающая выборка.

    Первая строка в списке выборок

    Затем вы создадите обучающую выборку Нарушение во временном срезе 1992-06-30.

  7. На ленте щелкните вкладку Многомерный. Для StdTime выберите временной срез 1992-06-30.
  8. На панели Классификация изображений щелкните класс Нарушение, чтобы выбрать его. Щелкните кнопку Полигон.
  9. На карте найдите участок нарушенного леса (белый) и оцифруйте полигон.
    Примечание:

    Если необходимо переместиться в другое местоположение, отображающее нарушенный лесной покров, удерживая нажатой клавишу C, перемещайте и масштабируйте изображение с помощью мыши.

    Второй полигон на карте

    Вторая обучающая выборка добавляется в список.

    В реальном рабочем процессе вы продолжили бы создавать обучающие выборки из разных временных срезов, чтобы накопить достаточное количество примеров для всех трех классов. Однако чтобы сэкономить время в этом руководстве, вы будете использовать набор обучающих выборок, которые были заранее подготовлены для вас.

  10. На панели Классификация изображений щелкните кнопку Загрузить обучающую выборку.

    Кнопка Загрузить обучающую выборку

  11. В окне Обучающие выборки дважды щелкните Базы данных и Forest_Disturbance_Analysis.gdb. Выберите WestCascade_training_samples.

    Файл обучающих выборок

  12. Нажмите OK.

    На панель добавляются обучающие примеры из файла.

    Обучающие выборки на панели Классификация изображений

    Список содержит около 80 выборок, каждая из которых имеет имя класса и дату временного среза.

  13. Дважды щелкните кнопку строки рядом с любой обучающей выборки в списке.

    Кнопка строки в обучающей выборке

    На карте появляется соответствующий полигон, отображаемый в правильном временном срезе.

  14. Закройте панель Классификация изображений. В окне предупреждения, спрашивающем, хотите ли вы сохранить изменения, выберите Нет.

    Вам не нужно вносить или сохранять какие-либо изменения в обучающие выборки.

  15. На панели Содержание щелкните правой кнопкой файл WestCascade_change_analysis.crf и выберите Приблизить к слою.
    Примечание:

    Эти обучающие выборки были собраны из растра анализа изменений, сгенерированного с точно такими же параметрами, как у вас. Использование другого растра анализа изменений, например, растра, созданного с другим значением параметра Дата привязки, недопустимо.

Выполнение классификации

Затем вы обучите классификатор, используя обучающие выборки. Вы примените это к временному ряду, чтобы классифицировать каждый пиксел каждого временного среза. Сначала вы будете использовать инструмент Обучающий классификатор произвольных деревьев.

  1. Щелкните вкладку Анализ на ленте. В группе Геообработка щелкните Инструменты.

    Кнопка Инструменты

    Откроется панель Геообработка.

  2. Введите в строке поиска Классификатор произвольных деревьев с обучением. В списке результатов поиска выберите Классификатор произвольных деревьев с обучением.

    Инструмент Классификатор произвольных деревьев с обучением в списке результатов поиска

  3. Для параметра Входной растр выберите WestCascade_change_analysis.crf. Отключите Использовать отфильтрованные записи.
  4. Для параметра Входной файл обучающей выборки щелкните кнопку Обзор.

    Кнопка Обзор

  5. В окне Входной файл обучающей выборки щелкните Базы данных и дважды щелкните Forest_Disturbance_Analysis.gdb. Выберите WestCascade_training_samples и нажмите ОК.
  6. Для Поле значения измерения выберите StdTime.
  7. Для параметра Выходной файл определения классификатора удалите текст и введите WestCascade_trained_classifier.ecd.

    Параметры Обучающего классификатора произвольных деревьев

  8. Щелкните Запустить.

    Инструмент создает файл определения классификации Esri (.ecd), который содержит статистику и классификационную информацию для каждого класса. Далее вы будете использовать этот обученный классификатор для классификации всего временного ряда с помощью инструмента Классифицировать растр.

  9. На панели Геообработка щелкните кнопку Назад.

    Кнопка Назад на панели Геообработка

  10. Найдите и откройте инструмент Классифицировать растр.
  11. Для параметра Входной растр выберите WestCascade_change_analysis.crf. Отключите Использовать отфильтрованные записи.
  12. Для Входной файл определения классификатора нажмите кнопку Обзор. Разверните Папки, Forest_Disturbance_Analysis и commondata.
  13. Выберите WestCascade_trained_classifier.ecd и нажмите ОК.
  14. Для Выходной классифицированный растр введите WestCascade_classification.crf.

    Параметры инструмента Классифицировать растр

  15. Щелкните Запустить.

    Используя информацию, содержащуюся в обученном классификаторе, инструмент классифицирует каждый пиксел каждого временного среза растра анализа изменений в один из трех целевых классов. Выходной многомерный растр CRF будет добавлен на карту. Это временной ряд, в котором каждый временной срез состоит из одноканального растра, содержащего значения классификации. По умолчанию отображается срез времени 1984-06-30.

    В легенде в панели Содержание перечислены три класса:

    • Участки темно-зеленого цвета классифицируются как Здоровый лес.
    • Области ярко-розового цвета классифицируются как Нарушенные.
    • Области, выделенные светло-зеленым цветом, классифицируются как Восстановленные.

    Слой классификации на карте

  16. На ленте щелкните вкладку Многомерный. В группе Срез текущего отображения щелкните Воспроизвести срезы по StdTime для создания анимации временных рядов.

    На анимации временного ряда видно, как участки здорового леса становятся ареалами нарушенного леса, а затем восстанавливаются.

  17. Когда вы закончите просмотр анимации, нажмите Воспроизвести разрезы по StdTime, чтобы остановить ее.

Суммирование изменений

Далее с помощью инструмента Суммировать категорийный растр вы вычислите суммарную статистику для трех классов в каждом временном срезе. Этот инструмент подсчитает количество пикселов, присвоенных каждому классу.

  1. На панели Геообработка щелкните кнопку Назад.
  2. Найдите и откройте инструмент Суммировать категорийный растр.
  3. Для Входной категорийный растр выберите WestCascade_classification.crf. Отключите Использовать отфильтрованные записи.
  4. Для параметра Выходная суммарная таблица введите Forest_types_table.

    Параметры инструмента Суммировать категорийный растр

  5. Щелкните Запустить.

    Инструмент запустится. В панели Содержание в разделе Автономные таблицы отображается выходная таблица. Далее вы создадите линейчатую диаграмму для отображения информации, содержащейся в таблице, сосредоточив внимание на классах Disturbance и Slow_Recovery.

  6. Закройте панель Геообработка.
  7. На панели Содержание щелкните правой кнопкой Forest_class_table, нажмите Построить диаграмму и выберите Линейчатая диаграмма.

    Опция Столбчатая диаграмма

    Откроется панель Свойства диаграммы с незаполненной диаграммой.

  8. На панели Свойства диаграммы для опции Категория или Дата выберите StdTime. Для Агрегирование выберите Сумма.

    Параметры Категория или дата и Агрегирование

  9. Для Числовые поля щелкните Выбрать. Отметьте Disturbance и Recovery и нажмите Применить.

    Свойства диаграммы

    Появится диаграмма. Вы отформатируете ее и добавите надписи для оптимизации отображения.

  10. На панели Свойства диаграммы перейдите на вкладку Серии.

    Вкладка Серии

  11. В списке полей в поле Нарушение щелкните символ и выберите Розовый пион.

    Цвет Розовый пион для символа Нарушенных областей

  12. Для Восстановления щелкните символ и выберите Зелёное яблоко, светлый.

    Цвет Зелёное яблоко, светлый для символа Восстановленных областей

  13. На панели Свойства диаграммы перейдите на вкладку Общие. Укажите параметры следующим образом:
    • Для Название диаграммы введите Классификация лесов (1984-2020).
    • В параметре Заголовок по оси X введите Год.
    • Для Заголовок по оси Y введите Число пикселов.

    Вкладка Общие диаграммы

    Диаграмма обновится.

    Диаграмма классификации лесов

    На этой диаграмме показаны тенденции динамики лесов за 35 лет. Она дает представление о балансе между нарушением и восстановлением лесной экосистемы. Очевидной тенденцией является взаимодополняющий характер динамики лесов; когда восстановление лесов высоко, нарушение лесов небольшое, и наоборот. Например, в 10-летнем интервале между 1992 и 2002 годами график показывает обратную зависимость, при которой восстановление лесов было высоким, а нарушения леса были относительно небольшими. В интервалах 1985-1990 годов и 2014-2020 годов нарушения увеличились по сравнению с восстановлением из-за заготовки древесины, что подтверждается снимками за эти годы.

  14. Сохраните проект.

Анализ изменений лесного покрова имеет решающее значение для оценки состояния лесов и биоразнообразия, а также для поддержки лесопользования, управления лесозаготовками, мониторинга потенциальной незаконной лесозаготовительной деятельности и многого другого. Решение этих задач требует мониторинга больших территорий с частыми интервалами времени и за разумную плату. LandTrendr - это эффективный инструмент картографирования для обнаружения и мониторинга ареалов нарушения и восстановления лесов. Он использует временные ряды изображений Landsat для автоматического обнаружения пространственных изменений в лесном покрове.

В этом руководстве вы использовали Анализатор изменения пикселов временных рядов для изучения изменений лесного покрова на уровне пиксела. Затем вы использовали инструменты Анализировать изменения с помощью LandTrendr и Определить изменения, используя растр анализа изменений для создания карт, выявляющих закономерности и тенденции в нарушении и процессе восстановления лесов на протяжении многих лет. Наконец, вы классифицировали растр анализа изменений на три класса, используя классификатор произвольных деревьев, и создали диаграмму, показывающую тенденции в динамике лесов за 35-летний период.

Больше подобных руководств вы можете найти в сборнике руководств Данные дистанционного зондирования и изображения.

Вы можете найти больше учебных пособий в галерее учебных пособий.